If a certain page on a website does not load for some reason or if a link is broken, the website visitor shall see an error page with a generic message. The page shall have nothing in common with the rest of the site, which can make the visitor leave the site. A likely solution in this case is a function made available from some website hosting providers - the option to set your own personalized error pages which shall have identical layout as your Internet site and that can contain any images or text you want based on the particular error. There are 4 standard errors which could take place and they involve these particular so-called HTTP status codes - 400, when your web browser sends a bad request to the hosting server and it cannot be processed; 401, in case you are supposed to log in to see some web page, but you have not done so yet; 403, if you do not have a permission to see a certain page; and 404, when a link which you've clicked leads to a file that doesn't exist. In all of these situations, visitors shall be able to see your personalized content instead of a generic error page.

Custom Error Pages in Semi-dedicated Servers

Including your own pages for any of the 4 error types to any site hosted through a semi-dedicated server account with us shall be very uncomplicated and shall not take more than a few mouse clicks. When you upload the files inside your account, you can go to the Hosted Domains section of your Hepsia CP and edit each of the domains and subdomains listed there using an intuitive interface with drop-down navigation. You can choose what page should appear for each error type. Your choices are a standard Apache server page or a page from our system, and custom pages. Should you select the aforementioned option, you need to input the link to every single page inside your account, then save the change. The link or the type of page which will appear in case a user encounters an error can be modified whenever you want. In case you’re more experienced, you could use an .htaccess file to be able to set in-house developed error pages too, rather than using our integrated generator tool, and if you select this option, the file has to be placed inside the root directory of a given domain or subdomain.